Color management theory

Devices are different
All digital devices are different. Most people know that monitors and printers are not alike, but even similar devices of the same brand can, and often will be different from each other even when new. They interpret or reproduce color differently. The easy way to see this for yourself is to visit a large TV shop and have a look at their wall of TV’s. Even if all are showing the same program, with the same input for all devices, none of the screen images will be exactly alike.

The same thing frequently happens with identical image data on two different printers, scanners or digital cameras. Same data, different device characteristics.

Colourspaces and ICC profiles
Now, the reason why devices are different is that they all have different color spaces or gamuts. That means that the devices aren’t all able to display the same colors, and that they have no concept of which colors they can or can’t display, and have no idea of how the colors will actually look when reproduced.

RGB devices, eg. Monitors, are superior at displaying Red, Green and Blue colors, because they work by projecting light on a dark surface (sort of). They are, however, not too good at reproducing Cyan, Magenta and Yellow.
Printers, on the other hand, are very good at doing Cyan, Magenta and Yellow, since they use pure inks of those exact colors. However, when it comes to reproducing, say, a blue color, then the printer can only render this by mixing Magenta and Cyan on paper, and this can’t possibly render a blue which is as bright and clear as the blue the monitor can display. Alas, there is a great deal of difference between the colors which monitors and printers can show.

To be able to predict how a color will look on a monitor (a printer, or other devices), we have to make a description to describe the character of each individual device, this profile describes exactly how each device reproduces color, compared to a known standard.

Colourspaces and Language
As an analogy you can compare color spaces to languages. You could say that each single device speaks a different language or dialect.

If we stick with that analogy, and the job at hand requires us to translate text from one language to another, we need 3 things:
1). We need to know which language the text is currently in.
2). We need to know which language the text should be translated to.
3). We either need a dictionary that translates directly from one language to another.
Or, 4). We need two different dictionaries, one that translates from our original language to a reference language and one that translates from that reference language to the destination language. Version 4 is how ICC profiles work, using Lab colourspace as the reference "language".

So in order to know exactly which language our monitor scanner, camera or printer "understands" we need to characterize each device.

That is, we need to create a dictionary between our reference language and our monitor, so we can translate color between our reference space and our device.
This characterization or dictionary is an ICC profile.
If we make a "monitor profile" which describes the characteristics of a particular monitor. We can
now translate colour data via the reference space [Lab] to the monitor space resulting in a true screen display.

**Source to destination**
To be able to rely on our monitor we require two profiles. One that describes the colour space our image is in, (workingspace to Lab), and one that describes our monitor (Lab to monitor). When we have these two profiles the computer is able to make a color data conversion and the colors we see on the monitor will be correct.

If we have another ICC profile which describes how our printer (inkjet, laser or even a printing press) prints color, then we can be pretty sure that whatever we print, will bear a close resemblance to what we see on the monitor.

So an ICC profile is really nothing more than a description of how a device displays colour, in reference to a known colour space.

**What you see is what you get**
If you have ICC profiles which describes all your different digital devices, and CMYK printing processes, then you can easily convert between devices, limiting loss of color to a absolute minimum, and with great reliability. Just think about it as if you need to translate text from, say Danish to German. All you need is a dictionary.

An ICC workflow would use say, Danish to Finnish and Finnish to German, thus making Finnish the reference language.

So with the proper profiles you can do some very interesting things:

- When working in (Colorsync savvy) camera or scanner software, you can use ICC profiles (of workningspace, monitor and source) to give you continuity of appearance between the way the camera or scanner software displays an image, and the appearance of that image once in Photoshop. This means that you can use the excellent colour and tonal editing tools in the scanner or camera software, confident in the knowledge that what work you have done on image optimisation will still be correct when you later open the image file in Photoshop.

- In your scanner, camera, or image manipulation software you can preview or "Softproof" a CMYK printing press output, by restricting the color space of your monitor to that of an offset printer, as long as you have a good profile of the printing press and monitor.

 o On your desktop printer you can simulate or "proof " how the final printed image will look, by
restricting the gamut of your desktop printer to that of an offset printer.
- On your monitor you can simulate or softproof your desktop printer output.

As mentioned earlier you can’t reproduce the exact same colors on a monitor as you can on a printer, but with the proper profiles, you can get very very close.

Now that you know how colormanagement works, implementing it is simply a question of obtaining profiles for your devices and setting up your applications correctly.

This is a 3D illustration showing how two color spaces look, namely Lab color (the cube) and the colorspace of a Mitsubishi monitor (the weird shape). Lab color is a theoretical colorspace which contains all colours the human eye can perceive, and is the reference space used when characterizing (profiling) monitors and printers. The whole concept of ICC color management is based on the premise that when you can describe how a device reproduces color in reference to Lab color you can easily convert images from one color space to another, just like you can translate words from one language to another using a dictionary.

Digital image data is unlikely to be stored in a working space which has exactly the same characteristics as your monitor. If you send this image data straight to your monitor then the display will, of course, be incorrect (it’s like speaking Danish to an American). If you have image data in a known working space and have a monitor profile, the colour management system can be used to ensure that the monitor display is correct by using the two profiles.

Next: Monitor Calibration ->
Monitor calibration

This is the most important step when thinking of CMS and quality image work. If this is not done on a regular basis, you may limit yourself in the quality of your work.

There are two basic methods:
1. You can use the Mac’s built-in feature called Adobe Gamma and make a visual calibration, or
2. you could invest in a hardware calibrator.

Monitor calibration and profiling is a two step process. Calibration involves setting various parameters usually on the monitor itself, so the monitor will yield the best possible result for our purposes. We call this optimising the hardware, a bit like tuning a guitar before playing. Profiling is the process of describing exactly how the calibrated monitor actually displays color, alas recording exactly how the guitar sounds when tuned.

While it is, indeed, possible to make a fairly good visual calibration of a monitor, with software utilities like Adobe Gamma, it does leave a lot of room for error. And validating a monitor profile is not an easy task which means you are never absolutely sure it’s done just right… So if you want to make sure, that what you see on your monitor is correct, there is no substitute for a good hardware calibration/profiling solution.

Today there are many manufacturers, providing these type of devices. We have tested a few and you could use them as a reference when purchasing a system.

The Spydar with PhotoCal or ColorCal software, from Colorvision.
www.colorcal.com

Any X-Rite monitor calibration product.
www.xrite.com

There are alot of other brands outthere, so if you prefer something else, that is you choice. These are just some of the products we use, and recommend.

To calibrate using Adobe Gamma

The Adobe Gamma is a control panel, and can be found in the control panel section of your Apple menu.

When opening the control panel, you get to choose between calibrating by a Step-by-step assistant, or a “all-in-one” control panel.
If you are new to monitor calibration, choose the assistant which will guide you through the process, and explain what all the different settings mean. When you then get experienced, og for the control panel user interface.

Now follow the instruction, and you will end up with a monitor profile. Remember to save it in the Colorsync profiles folder. This is located inside your Systems folder.
Always give the profile a name that will tell the most of the settings you have done ex. “Hitatchi 65K/22D” means the monitor is a Hitachi, the White point is 6500 Kelvin degrees.
The gamma has been set to 2.2 (even on a Mac!), now stick to that name each time you do a new calibration. Just overwrite the existing to avoid confusion.

It is recommended to re-calibrate at least once, each week.

"Why is the gamma set to 2.2, you are on a Macintosh, and everybody knows that needs to be 1.8??" -
Well to many it would not make a difference, but to tell the short story; All Apple Macintosh manufactured monitors, is always 1.8. Any other manufacture is 2.2, as these monitors have not been made specific for Mac’s and has therefore a different larger Gamut.
Now some may disagree on this disposition, but remember this is not a strict guideline to follow, just an indication of what we think is generally a good idea. If you believe in 1.8, then 1.8 it is…

If you have spent the extra money on a hardware calibrator, then follow the manufacturers specifications about using the device.

To tell the difference of quality, between visual calibration and using a hardware calibrator, you could say that the accuracy of the visual method is only as good as the eyes of the user! The calculated distance to 100% accuracy is, that when using visual calibration, the screen is about 20% off from the ultimate result.
"Now, does that matter to me", you might say. It is all up to your attitude towards what level of results you want to create with your scanner or digital camera back.

With a hardware calibrator, you are closer than 5% from the optimal setting of the monitor. This is roughly because you have no chances of seeing the colors differently, and all is calculated towards a digital reference.

The Colorsync Setup

ColorSync control panel (Mac), when you open the ColorSync control panel you will see two tabs, one called Profiles and one called CMMs. Under CMMs we recommend you to select the Heidelberg CMM. In the Profiles tab there is a pop-up menu, and in this you should select Profiles for Standard Devices first. Under Display you should make sure that the monitor profile you’ve created is selected here.
If it isn’t, you need to go to the Monitors & Sounds control panel and, under Color, select the correct profile here. All ColorSync aware applications will check with this control panel to ascertain which monitor profile to use to display your images.
The other 3 settings (Input, Output and Proofer) are currently used by only 5 or 6 applications,

but they will probably have wider support in the future, and no harm is done by setting these. Input should be set to your current used input profile (scanner or camera profile), Output is your final destination profile, usually a CMYK profile, and Proofer is the profile that describes the desktop printer you print to, for example an Epson SC 760.
Now it is quite possible that you have multiple setups, and need to use different profiles for different purposes, and for that reason you can save different sets of profiles by choosing File > ColorSync Workflows and save different sets of information.

The other setting you can choose in the Pop-up menu is Default Profiles For Documents. In here you can define default profiles (RGB, CMYK, Gray and Lab) for documents. That means that new document created in various color spaces, will have these profiles embedded in them, and that documents without profiles will be assumed to be in the colorspace selected here.

Currently only Photoshop allows users to use these settings and even Photoshop does not refer to the settings by default, however this may change sometime in the future. Currently there is no real need to use these settings.

**Color management settings in ColorFlex**

Color management in ColorFlex is very easy to overlook. Under File > Setup click the ColorSync tab at the far right. You already have all the input or source profiles you need after doing a standard install of ColorFlex, and you will have a number of Imacon CMYK profiles too. If you have Photoshop 6.0+ installed you’ll have the most common RGB working spaces as well.

Remember that the input profile is supposed to describe the colorspace of your input, so you will need different input profiles for different sources.

Please note that when you select a standard setup, the correct input profile is automatically selected for both the FlexFrame camera and the Flextight scanner range, regardless of what you work with.

![Image of ColorFlex setup](image)

Example of the RGB Standard and CMYK Standard setup, configured correctly.

First of all click the New button at the lower left corner of the dialogue, and name your setting with a logical name of your choice, like "My FlexFrame RGB" if you use the FlexFrame camera. In the ICC profiles field you need to select Input, RGB and CMYK profiles.

Input is the input profile or source profile.

For scanning transparencies on a Flextight scanner you should use the profile called Flextight and then the name of your scanner, so for a Flextight Precision scanner you would use the "Flextight Precision" profile under input. A Flextight Photo scanner would require a "Flextight Photo" profile for transparencies and so on.

If you scan either color or B&W negatives you should use the "Flextight Input" profile, no matter what scanner you use.

If you use the FlexFrame digital camera you should use the FlexFrame Default profile.

RGB is where you select an RGB profile that corresponds with your Working space of choice in Photoshop. So if you for example have chosen to use the Adobe RGB (1998) working space in Photoshop, you should choose this under RGB in ColorFlex software as well.

CMYK is where you can select which CMYK profile you want to convert your images to, if you want to scan/shoot directly into CMYK. You can find a description of what each CMYK profile is targeted for, in the FlexFrame or Flextight manual. Choose whichever you find useful, depending
on the preferences you have.
If you decide to convert your images to CMYK in ColorFlex, you should set the CMYK profile you choose, also as your default CMYK Workingspace in Adobe Photoshop. See details on how to do this later.
Now you only have a few checkboxes left, before you are done.

Convert is the one to check if you want to convert your raw image from your input space to your RGB or CMYK space. Which of the two is used depends on which mode you have chosen to use (RGB or CMYK). We recommend that you convert your raw scans to RGB, rather than leave them in the original color space [that of your scanner or camera].

Embed Profile will embed the correct ICC profile in all your images. This should always be checked so that other applications down the imaging chain will be able to recognize which color space the file is in.

Softproof should only be used if you if you want to convert your images to CMYK. If this is checked you will have the best possible simulation of how your image will look when printed on the device (printer) that your CMYK profile describes.

At this point when you have set up everything to your liking, you should click Save to save all the settings, so you can easily pick this entire set of profiles/settings under the Setup field, in the primary software interface window, or here in the ColorSync tab. This setting can be copied to other computers using ColorFlex, so other workstations easily can be set up to use the same settings that you do.

**Colormanagement setup in Adobe ®Photoshop® 6.0**

When you are working with both ColorFlex and Photoshop it makes sense to set up both applications alike, so they are in “sync”. Based on the way we set up ColorFlex before, we’ll go ahead and setup Photoshop in a similar manner.

Under Edit > Color settings you will find all Photoshop’s color settings. First off you need to check the advanced Mode checkbox at the top left corner. If you don’t do this you won’t be able to select any of the Imacon CMYK profiles.

Under Working Spaces set RGB to the same space you set RGB to in Colorflex. We recommend using Adobe RGB (1998) since this workingspace practically encompasses all the colours you will need for later re-production.

Under CMYK you need to select the CMYK profile that describes a printing process you want to convert your images to. You can find a description of what each of the Flextight CMYK profiles is targeted for, in the FlexFrame or Flextight manual. We have selected the Imacon 350% Skel.K. 90/30% here, as this profile is useful for good sheetfed offset. If you have chosen to convert your scans or digital photos to CMYK in ColorFlex, you should choose the same CMYK profile in both applications.

Under Gray (for grayscale) you can choose whether you want your grayscale images targeted for print, or for monitor display. If you work with images which is to be printed, and you can not obtain accurate information from your printer, you’ll need to estimate how much dot gain the printing process has, and set this.

If I had to recommend any, say for offset work in Europe, 15% would be a good start. In the US I would recommend 20%. If you target grayscale images for monitor use, I would choose the same gamma as your workingspace use. Adobe RGB (1998) and sRGB use Gamma 2.2, Apple RGB and ColorMatch RGB use gamma 1.8.

Under Spot (for spot colors) you need to estimate how much dot gain the printing process has, and set this. For offset work in Europe again I would say 15% would be a good start and and in the US 20% would be my recommendation, if you can not obtain accurate information from your printer.

**Color management Policies**

This is the place where you set up, in general, how Photoshop should treat images when opening
them. We'll recommend choosing Preserve Embedded Profiles for RGB and CMYK, and Convert to Working Gray under Gray.

Underneath there are a few check boxes, that allow various warning dialogues to pop up when you open images. We recommend you to check all these.

In Conversion Options under Engine you should choose either Adobe (ACE) or Heidelberg CMM.

Under Intent you should pick Perceptual, as opposed to the default.

The check boxes Use Black Point Compensation and Use Dither should be checked.

In Advanced Controls nothing should be checked.

Now hit the Save button and name this entire group of settings to your liking. You can also write a description that explains what the settings do. This group of settings can be copied to other computers using Photoshop 6.0+, so other workstations easily can be set up to use the same settings that you do. Simply select the entire setting under Settings at the top of the window, or by clicking Load and navigating to wherever the previously saved setting currently is.

If you have been following our advice so far the following will happen:

1). You are shooting/scanning and converting to your RGB workspace [we suggested Adobe RGB (1998)] in ColorFlex. When this image is opened in Photoshop you won’t get any warning dialog as your image data has been converted on the fly, during capture, to your RGB workspace. The monitor image in Photoshop, will be identical to the one in ColorFlex.

2) You are shooting/scanning in RGB in ColorFlex, and have chosen not to convert to your RGB Space, but only to Embed a profile.

When opening this image in Photoshop you will be presented with a Profile Mismatch, telling you what profile is embedded (what colorspace the image is in), and asking you what to do.

There are two sensible routes to go:
A. You can convert to your working space.
B. You can choose to Preserve the Embedded Profile.

Both routes will give you a monitor image in Photoshop, which is identical to your preview in ColorFlex.
However, because of issues with making edits to the colour or tone of images in non-linear colourspaces [like certain scanner spaces] we would recommend you make the conversion to your Photoshop working space.

3) You are shooting/scanning and converting to CMYK in ColorFlex. When this image is opened in Photoshop you won’t get any warning dialogues as your your image data has been converted on the fly, while saving, to your CMYK workspace. If you have clicked the softproof check button in ColorFlex, the on screen image in ColorFlex will be virtually identical to the one in Photoshop.

**Colormanagement setup in Adobe® Photoshop® 5+**

A little bit different than in 6.0. However a lot of the guidelines from 6.0 apply, so this section will only be to show how it looks in 5+.

Instead of one combined panel, there are three. All of them, can be found under the File> Color Settings tab.

![RGB Setup](image)

The RGB setup, configured with the Adobe RGB (1998)

Now in PS 5+ it did not automatically create RGB profiles in your Colorsync folder. To make it possible to scan direct to the desired colorspace you will have to save this setup, in your Colorsync profiles folder. This is located in your systems folder.

Remember to save it under the exact same name, to avoid any confusion.
The CMYK setup looks like this.

![CMYK Setup](image1)

Now in PS5+ The *Black Point Compensation* is off, compared to PS6.

![Profile Setup](image2)

And as the last thing to do, the Profile setup.

We hope this manual, gave you not only insight and understanding in what Colormanagement is, but also how to use it.

Thomas Holm/Pixl and IMACON Support

visit the web : www.imacon.dk